summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-02-04 14:15:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:13 +0100
commitfbf76ad58399d0168ea43a9d4ecf48bba91955d8 (patch)
tree518bf932bf383b537367275b38b6b83775905645 /gnu/packages
parent50de6fde50470db76372d5df4acbcba94c61b7d2 (diff)
downloadpatches-fbf76ad58399d0168ea43a9d4ecf48bba91955d8.tar
patches-fbf76ad58399d0168ea43a9d4ecf48bba91955d8.tar.gz
gnu: Add r-semplot.
* gnu/packages/cran.scm (r-semplot): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8a0dc2de48..fa11470aa7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20060,3 +20060,42 @@ plotting methods, and tools for psychometric data visualization and graphical
model estimation. See Epskamp et al. (2012)
@url{doi:10.18637/jss.v048.i04}.")
(license license:gpl2)))
+
+(define-public r-semplot
+ (package
+ (name "r-semplot")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "semPlot" version))
+ (sha256
+ (base32
+ "0l1v9yi1pv59iwfknw4dh9qskk5y8r347jq1vq13gnfd3bmd71xr"))))
+ (properties `((upstream-name . "semPlot")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-colorspace" ,r-colorspace)
+ ("r-corpcor" ,r-corpcor)
+ ("r-igraph" ,r-igraph)
+ ("r-lavaan" ,r-lavaan)
+ ("r-lisreltor" ,r-lisreltor)
+ ("r-openmx" ,r-openmx)
+ ("r-plyr" ,r-plyr)
+ ("r-qgraph" ,r-qgraph)
+ ("r-regsem" ,r-regsem)
+ ("r-rockchalk" ,r-rockchalk)
+ ("r-sem" ,r-sem)
+ ("r-xml" ,r-xml)))
+ (home-page "https://github.com/SachaEpskamp/semPlot")
+ (synopsis "Unified visualizations of structural equation models")
+ (description
+ "Structural equation modeling (SEM) has a long history of representing
+models graphically as path diagrams. The semPlot package for R fills the gap
+between advanced, but time-consuming, graphical software and the limited
+graphics produced automatically by SEM software. In addition, semPlot offers
+more functionality than drawing path diagrams: it can act as a common ground
+for importing SEM results into R. Any result usable as input to semPlot can
+also be represented in any of the three popular SEM frame-works, as well as
+translated to input syntax for the R packages @code{sem} and @code{lavaan}.")
+ (license license:gpl2)))