summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-02-04 14:10:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:12 +0100
commitc86473c2281cec91bcf166646f565ae7fb1c1547 (patch)
tree43bb25e94431fe59968758dd244d27b342519dfb /gnu/packages
parentfe0020609a2e6287b31aae1159cb11dfc9506ca2 (diff)
downloadpatches-c86473c2281cec91bcf166646f565ae7fb1c1547.tar
patches-c86473c2281cec91bcf166646f565ae7fb1c1547.tar.gz
gnu: Add r-rockchalk.
* gnu/packages/cran.scm (r-rockchalk): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bda87d1a2d..32b3b23274 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19891,3 +19891,33 @@ visual summary for each variable in a data frame. The main feature here is
the systematic implementation of the \"variable key\" framework for data
importation and recoding.")
(license license:gpl2)))
+
+(define-public r-rockchalk
+ (package
+ (name "r-rockchalk")
+ (version "1.8.144")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rockchalk" version))
+ (sha256
+ (base32
+ "07dp1n155b9gfvk8l30h6bhjbhbylsjxfzns08mryn4mxj3nqpnb"))))
+ (properties `((upstream-name . "rockchalk")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cardata" ,r-cardata)
+ ("r-kutils" ,r-kutils)
+ ("r-lme4" ,r-lme4)
+ ("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/package=rockchalk")
+ (synopsis "Regression estimation and presentation")
+ (description
+ "This package provides a collection of functions for interpretation and
+presentation of regression analysis. These functions are used to produce the
+statistics lectures in @url{http://pj.freefaculty.org/guides}. The package
+includes regression diagnostics, regression tables, and plots of interactions
+and \"moderator\" variables. The emphasis is on \"mean-centered\" and
+\"residual-centered\" predictors. The vignette @code{rockchalk} offers a
+fairly comprehensive overview.")
+ (license license:gpl3+)))