summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-29 18:13:12 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-08-30 11:10:59 +0300
commit5796215a73c3d104ebe497cf3d1a33c9f2c85e72 (patch)
treea614e88d55d0530fd22240325ff60a8f06e80737 /gnu/packages
parented51d4206375b13e63a7518907fb4e1bda888976 (diff)
downloadpatches-5796215a73c3d104ebe497cf3d1a33c9f2c85e72.tar
patches-5796215a73c3d104ebe497cf3d1a33c9f2c85e72.tar.gz
gnu: Add emacs-helm-taskrunner.
* gnu/packages/emacs-xyz.scm (emacs-helm-taskrunner): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3024f78716..9e94d3fc8e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6394,6 +6394,33 @@ multiple project types.")
Makefile targets.")
(license license:gpl3+))))
+(define-public emacs-helm-taskrunner
+ (let ((commit "1910dac19cbc7bd4fd08b0faf9affd455339fbea")
+ (revision "1"))
+ (package
+ (name "emacs-helm-taskrunner")
+ (version (git-version "0.9" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-taskrunner/helm-taskrunner.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "182lmr858fx6rdhp1fy7kv8dvrhzcnxzwfck1q22s6xs8x85d5q7"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-taskrunner" ,emacs-taskrunner)
+ ("emacs-projectile" ,emacs-projectile)))
+ (home-page "https://github.com/emacs-taskrunner/helm-taskrunner")
+ (synopsis "Retrieve build-system tasks using Helm")
+ (description "This package provides a Helm interface for selecting
+Makefile targets.")
+ (license license:gpl3+))))
+
(define-public emacs-helm-make
(let ((commit "feae8df22bc4b20705ea08ac9adfc2b43bb348d0")
(revision "1"))