summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-15 22:19:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-19 01:19:33 +0100
commitfffcd8b829d1fbd8bdb6af85385033224c576cec (patch)
treea23659bc9ab5b24b7270991c25f94acb975f3e06 /gnu/packages
parent8ef8de799fcbc7b1a04be0d33e1183c766d0f893 (diff)
downloadpatches-fffcd8b829d1fbd8bdb6af85385033224c576cec.tar
patches-fffcd8b829d1fbd8bdb6af85385033224c576cec.tar.gz
gnu: python-pbkdf2: Fix tests.
* gnu/packages/python.scm (python-pbkdf2)[arguments]: Replace 'check' phase with custom command.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fff9a666a6..70aa8cd665 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12967,6 +12967,15 @@ protocols written in pure Python.")
(base32
"0yb99rl2mbsaamj571s1mf6vgniqh23v98k4632150hjkwv9fqxc"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) "/build/lib:"
+ (getenv "PYTHONPATH")))
+ (zero? (system* "python" "test/test_pbkdf2.py")))))))
(propagated-inputs
`(("python-pycrypto" ,python-pycrypto))) ; optional
(home-page "http://www.dlitz.net/software/python-pbkdf2/")