summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-31 15:19:14 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-31 15:23:06 +0200
commit44b0faee6bb76c73384d42af95e492329fd45842 (patch)
tree76526a7b2307926eed513b7a1860254b8f1f3a14 /gnu/packages
parent8ecba89b7777a21b633f9807b997076e4e5c210d (diff)
downloadpatches-44b0faee6bb76c73384d42af95e492329fd45842.tar
patches-44b0faee6bb76c73384d42af95e492329fd45842.tar.gz
gnu: guile-git: Skip faulty tests on non-x86_64.
Reported by Mark H Weaver. * gnu/packages/guile.scm (guile-git)[arguments]: Add 'skip-tests' phase unless on x86_64-linux.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6011e85162..376cdeede8 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1822,10 +1822,22 @@ is not available for Guile 2.0.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(#:phases (modify-phases %standard-phases
(add-after 'unpack 'bootstrap
(lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ (zero? (system* "autoreconf" "-vfi"))))
+
+ ;; FIXME: On i686, bytestructures miscalculates the offset
+ ;; of the 'old-file' and 'new-file' fields within the
+ ;; '%diff-delta' structure.
+ ,@(if (string=? (%current-system) "x86_64-linux")
+ '()
+ '((add-before 'check 'skip-tests
+ (lambda _
+ (substitute* "Makefile"
+ (("tests/status\\.scm")
+ ""))
+ #t)))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)