summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-08 23:57:29 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-08 23:57:29 +0100
commit7894ea6122aa21493f4815b7de3ea42781d6b3d6 (patch)
tree5a04583c50df6cf02f2e82e168db1b316bec3f99 /gnu/packages
parentb66d6d52ccaef0ffc660df9077500ca52e3ab35f (diff)
downloadpatches-7894ea6122aa21493f4815b7de3ea42781d6b3d6.tar
patches-7894ea6122aa21493f4815b7de3ea42781d6b3d6.tar.gz
gnu: gcc-arm-none-eabi-4.9: Remove non-applicable patch.
* gnu/packages/embedded.scm (gcc-arm-none-eabi-4.9)[patches]: Remove "gcc-arm-bug-71399.patch" from XGCC's patches.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/embedded.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index c4d05605a8..bd064e618f 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -38,7 +38,8 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages texinfo))
+ #:use-module (gnu packages texinfo)
+ #:use-module (srfi srfi-1))
;; We must not use the released GCC sources here, because the cross-compiler
;; does not produce working binaries. Instead we take the very same SVN
@@ -63,7 +64,13 @@
(sha256
(base32
"113r98kygy8rrjfv2pd3z6zlfzbj543pq7xyq8bgh72c608mmsbr"))
- (patches (origin-patches (package-source xgcc)))))
+
+ ;; Remove the one patch that doesn't apply to this 4.9 snapshot (the
+ ;; patch is for 4.9.4 and later but this svn snapshot is older).
+ (patches (remove (lambda (patch)
+ (string=? (basename patch)
+ "gcc-arm-bug-71399.patch"))
+ (origin-patches (package-source xgcc))))))
(native-inputs
`(("flex" ,flex)
,@(package-native-inputs xgcc)))