summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-13 16:44:02 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-13 23:12:43 +0100
commit59e80445882f8b0379e54916f89510c0deda6698 (patch)
tree2769fffa217f630349c5a7207ee92204af046f9d /gnu/packages
parent13f62aef2d87dc888f89fea3260eaa39938e6640 (diff)
downloadpatches-59e80445882f8b0379e54916f89510c0deda6698.tar
patches-59e80445882f8b0379e54916f89510c0deda6698.tar.gz
Remove traces of "GuixSD".
* gnu/bootloader/extlinux.scm (extlinux-configuration-file): Remove mentions of "GuixSD". * gnu/bootloader/grub.scm (install-grub-efi): Likewise. * gnu/build/vm.scm (make-iso9660-image): Change default #:volume-id to "Guix_image". (initialize-hard-disk): Search for the "Guix_image" label. * gnu/ci.scm (system-test-jobs, tarball-jobs): Remove "GuixSD". * gnu/installer/newt/welcome.scm (run-welcome-page): Likewise. * gnu/packages/audio.scm (supercollider)[description]: Likewise. * gnu/packages/curl.scm (curl): Likewise. * gnu/packages/emacs.scm (emacs): Likewise. * gnu/packages/gnome.scm (network-manager): Likewise. * gnu/packages/julia.scm (julia): Likewise. * gnu/packages/linux.scm (alsa-plugins): Likewise. (powertop, wireless-regdb): Likewise. * gnu/packages/package-management.scm (guix): Likewise. * gnu/packages/polkit.scm (polkit): Likewise. * gnu/packages/tex.scm (texlive-bin): Likewise. * gnu/services/base.scm (file-systems->fstab): Likewise. * gnu/services/cups.scm (%cups-activation): Likewise. * gnu/services/mail.scm (%dovecot-activation): Likewise. * gnu/services/messaging.scm (prosody-configuration)[log]: Likewise. * gnu/system/examples/vm-image.tmpl (vm-image-motd): Likewise. * gnu/system/install.scm (installation-os)[file-systems]: Change root file system label to "Guix_image". * gnu/system/mapped-devices.scm (check-device-initrd-modules): Remove "GuixSD". * gnu/system/vm.scm (system-docker-image): Likewise. (system-disk-image)[root-label]: Change to "Guix_image". * gnu/tests/install.scm (run-install): Remove "GuixSD". * guix/modules.scm (guix-module-name?): Likewise. * nix/libstore/optimise-store.cc: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm2
-rw-r--r--gnu/packages/curl.scm2
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/julia.scm2
-rw-r--r--gnu/packages/kde-frameworks.scm2
-rw-r--r--gnu/packages/linux.scm6
-rw-r--r--gnu/packages/package-management.scm4
-rw-r--r--gnu/packages/polkit.scm2
-rw-r--r--gnu/packages/tex.scm2
10 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 91bb467de6..8bcd3c4b85 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2270,7 +2270,7 @@ for experimenting with sound synthesis and algorithmic composition.
SuperCollider requires jackd to be installed in your user profile and your
user must be allowed to access the realtime features of the kernel. Search
for \"realtime\" in the index of the Guix manual to learn how to achieve this
-using GuixSD.")
+using Guix System.")
(license license:gpl2+)))
(define-public raul
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 822fe17036..456a18012d 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -108,7 +108,7 @@
(("/bin/sh") (which "sh")))
;; XXX FIXME: Test #1510 seems to work on some machines and not
- ;; others, possibly based on the kernel version. It works on GuixSD
+ ;; others, possibly based on the kernel version. It works on Guix System
;; on x86_64 with linux-libre-4.1, but fails on Hydra for both i686
;; and x86_64 with the following error:
;;
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1e76f0821c..74005972db 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -92,7 +92,7 @@
'("eshell/esh-groups.el")))
;; Make sure Tramp looks for binaries in the right places on
- ;; remote GuixSD machines, where 'getconf PATH' returns
+ ;; remote Guix System machines, where 'getconf PATH' returns
;; something bogus.
(substitute* "net/tramp-sh.el"
;; Patch the line after "(defcustom tramp-remote-path".
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0344e42444..3d67b7b9c1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5161,7 +5161,7 @@ users.")
(doc (assoc-ref %outputs "doc"))
(dhclient (string-append (assoc-ref %build-inputs "isc-dhcp")
"/sbin/dhclient")))
- (list "--with-systemd-logind=yes" ;In GuixSD, this is provided by elogind.
+ (list "--with-systemd-logind=yes" ;In Guix System, this is provided by elogind.
"--with-consolekit=no"
"--with-crypto=gnutls"
"--disable-config-plugin-ibft"
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index a2e1264503..fa9709c40c 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -148,7 +148,7 @@
(use-modules (ice-9 match))
(substitute* "src/runtime_ccall.cpp"
;; Patch out invocations of '/sbin/ldconfig' to avoid getting
- ;; error messages about missing '/sbin/ldconfig' on GuixSD.
+ ;; error messages about missing '/sbin/ldconfig' on Guix System.
(("popen\\(.*ldconfig.*\\);")
"NULL;\n")
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 2ae5feaf52..10a1dfe0d1 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3487,7 +3487,7 @@ workspace.")
("qtsvg" ,qtsvg)
("qttools" ,qttools)
("qtx11extras" ,qtx11extras)))
- ;; FIXME: Use GuixSD ca-bundle.crt in etc/xdg/ksslcalist and
+ ;; FIXME: Use Guix ca-bundle.crt in etc/xdg/ksslcalist and
;; share/kf5/kssl/ca-bundle.crt
;; TODO: NixOS has nix-kde-include-dir.patch to change std-dir "include"
;; into "@dev@/include/". Think about whether this is needed for us, too.
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e4a58834a9..1cdffb8c79 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1112,7 +1112,7 @@ MIDI functionality to the Linux-based operating system.")
(outputs '("out" "pulseaudio" "jack"))
(arguments
`(#:configure-flags '(;; Do not install a "local" configuration targeted
- ;; for /etc/alsa. On GuixSD plugins are loaded from
+ ;; for /etc/alsa. On Guix System plugins are loaded from
;; the ALSA service, and other distributions likely
;; won't use these files.
"--with-alsalconfdir=/tmp/noop")
@@ -1579,7 +1579,7 @@ devices. It replaces @code{iwconfig}, which is deprecated.")
'(#:phases
(modify-phases %standard-phases
;; TODO: Patch some hardcoded "wlan0" in calibrate/calibrate.cpp to
- ;; allow calibrating the network interface in GuixSD.
+ ;; allow calibrating the network interface in Guix System.
(add-after 'unpack 'patch-absolute-file-names
(lambda* (#:key inputs #:allow-other-keys)
(let ((kmod (assoc-ref inputs "kmod")))
@@ -2379,7 +2379,7 @@ compliance.")
#:tests? #f ;no tests
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list (string-append "PREFIX=" out)
- (string-append "LSB_ID=GuixSD")
+ (string-append "LSB_ID=Guix")
(string-append "DISTRO_PUBKEY=/dev/null")
(string-append "DISTRO_PRIVKEY=/dev/null")
(string-append "REGDB_PUBKEY=/dev/null")
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 1244cf2fc3..86e8fce1dc 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -142,8 +142,8 @@
;; Set 'DOT_USER_PROGRAM' to the empty string so
;; we don't keep a reference to Graphviz, whose
- ;; closure is pretty big (too big for the GuixSD
- ;; installation image.)
+ ;; closure is pretty big (too big for the Guix
+ ;; system installation image.)
"ac_cv_path_DOT_USER_PROGRAM=dot"
;; To avoid problems with the length of shebangs,
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 0433b423eb..ba74a5c905 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -73,7 +73,7 @@
(substitute* "src/polkitbackend/polkitbackendjsauthority.cpp"
(("systemd") "elogind"))
- ;; GuixSD's polkit service stores actions under
+ ;; Guix System's polkit service stores actions under
;; /etc/polkit-1/actions.
(substitute* "src/polkitbackend/polkitbackendinteractiveauthority.c"
(("PACKAGE_DATA_DIR \"/polkit-1/actions\"")
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 584b2bcfa5..5b29937672 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -185,7 +185,7 @@
;; ps2eps.pl uses the "gswin32c" ghostscript executable on Windows,
;; and the "gs" ghostscript executable on Unix. It detects Unix by
;; checking for the existence of the /usr/bin directory. Since
- ;; GuixSD does not have /usr/bin, it is also detected as Windows.
+ ;; Guix System does not have /usr/bin, it is also detected as Windows.
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "utils/ps2eps/ps2eps-src/bin/ps2eps.pl"
(("gswin32c") "gs"))