summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:20:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:18 +0100
commit2331bf2a64f06fac24e1ce9fb0b5614ffb98c160 (patch)
tree86f0b83d3be346940b2f559140c4df7de43a5425 /gnu/packages
parentb6933ea634f5522e64a61c83771fa28b78948acd (diff)
downloadpatches-2331bf2a64f06fac24e1ce9fb0b5614ffb98c160.tar
patches-2331bf2a64f06fac24e1ce9fb0b5614ffb98c160.tar.gz
gnu: Add r-extrafont.
* gnu/packages/cran.scm (r-extrafont): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2eacf24610..00b6734b80 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13010,3 +13010,36 @@ interaction search in high-dimensional data.")
(description
"This package holds the database for the @code{extrafont} package.")
(license license:gpl2)))
+
+(define-public r-extrafont
+ (package
+ (name "r-extrafont")
+ (version "0.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "extrafont" version))
+ (sha256
+ (base32
+ "0b9k2n9sk23bh45hjgnkxpjyvpdrz1hx7kmxvmb4nhlhm1wpsv9g"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-extrafontdb" ,r-extrafontdb)
+ ("r-rttf2pt1" ,r-rttf2pt1)))
+ (home-page "https://github.com/wch/extrafont")
+ (synopsis "Tools for using fonts in R")
+ (description
+ "The extrafont package makes it easier to use fonts other than the basic
+PostScript fonts that R uses. Fonts that are imported into extrafont can be
+used with PDF or PostScript output files. There are two hurdles for using
+fonts in PDF (or Postscript) output files:
+
+@enumerate
+@item Making R aware of the font and the dimensions of the characters.
+@item Embedding the fonts in the PDF file so that the PDF can be displayed
+ properly on a device that doesn't have the font. This is usually needed if
+ you want to print the PDF file or share it with others.
+@end enumerate
+
+The extrafont package makes both of these things easier.")
+ (license license:gpl2)))