summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:44:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commit09dde7fb01b3685f1549661d50aeecb18696bc05 (patch)
treecb237429242f9c1a4d8b5a50835086d7805ea581 /gnu/packages
parent91e06bedf8ae43722c8c8b50816fa4e90593932e (diff)
downloadpatches-09dde7fb01b3685f1549661d50aeecb18696bc05.tar
patches-09dde7fb01b3685f1549661d50aeecb18696bc05.tar.gz
gnu: Add r-polyclip.
* gnu/packages/cran.scm (r-polyclip): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b0fb5ec86a..1690320879 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13221,3 +13221,28 @@ data that can be used as basis for animation. Furthermore it adds a number of
vectorized interpolaters for common R data types such as numeric, date and
color.")
(license license:expat)))
+
+(define-public r-polyclip
+ (package
+ (name "r-polyclip")
+ (version "1.10-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "polyclip" version))
+ (sha256
+ (base32
+ "0jyk4maqiblvj095jd59dr76kbniyli3v3xvy0a72ljszq6vrnkl"))))
+ (build-system r-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.angusj.com/delphi/clipper.php")
+ (synopsis "Polygon clipping")
+ (description
+ "This package provides an R port of the library Clipper. It performs
+polygon clipping operations (intersection, union, set minus, set difference)
+for polygonal regions of arbitrary complexity, including holes. It computes
+offset polygons (spatial buffer zones, morphological dilations, Minkowski
+dilations) for polygonal regions and polygonal lines. It computes the
+Minkowski Sum of general polygons. There is a function for removing
+self-intersections from polygon data.")
+ (license license:boost1.0)))