summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:40:11 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:04 +0100
commit7ec9a45db3ad4b57bf6fc94ad25b8f6f091e5c0e (patch)
tree549a8a86b7f81fae962aa3f3bbdeab3e9d5e1725 /gnu/packages
parent6018802d9cea508cd7213db5da609c4f4158dd32 (diff)
downloadpatches-7ec9a45db3ad4b57bf6fc94ad25b8f6f091e5c0e.tar
patches-7ec9a45db3ad4b57bf6fc94ad25b8f6f091e5c0e.tar.gz
gnu: Add ocaml-ppx-assert.
* gnu/packages/ocaml.scm (ocaml-ppx-assert): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f750843fa6..c106229552 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5718,3 +5718,30 @@ match expressions, and if expressions.")
(description "Syntax extension that makes [failwiths] always include a
position.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-assert
+ (package
+ (name "ocaml-ppx-assert")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/ppx_assert-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "17kd311n0l9f72gblf9kv8i5rghr106w37x4f0m5qwh6nlgl0j9k"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-ppx-compare" ,ocaml-ppx-compare)
+ ("ocaml-ppx-here" ,ocaml-ppx-here)
+ ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_assert")))
+ (home-page "https://github.com/janestreet/ppx_assert")
+ (synopsis "Assert-like extension nodes that raise useful errors on failure")
+ (description "This package contains assert-like extension nodes that raise
+useful errors on failure.")
+ (license license:asl2.0)))