summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-17 03:15:11 -0400
committerMark H Weaver <mhw@netris.org>2018-03-17 03:35:58 -0400
commit190376a1ca457ecce3f2bebe1d56392ac07929fd (patch)
treef8f88c8cde368c385fa43ace5f0b3eca2cc98754 /gnu/packages
parent9f388b1ee1733d84edff7f473cbcbc4ab42b7128 (diff)
downloadpatches-190376a1ca457ecce3f2bebe1d56392ac07929fd.tar
patches-190376a1ca457ecce3f2bebe1d56392ac07929fd.tar.gz
gnu: unzip: Ungraft.
* gnu/packages/compression.scm (unzip)[replacement]: Remove field. [arguments]: Add 'fortify' phase. (unzip/fixed): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/compression.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 3f486d38c1..dbf4f925a3 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1740,7 +1740,6 @@ Compression ratios of 2:1 to 3:1 are common for text files.")
(define-public unzip
(package (inherit zip)
(name "unzip")
- (replacement unzip/fixed)
(version "6.0")
(source
(origin
@@ -1768,6 +1767,13 @@ Compression ratios of 2:1 to 3:1 are common for text files.")
(arguments
`(#:phases (modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'fortify
+ (lambda _
+ ;; Mitigate CVE-2018-1000035, an exploitable buffer overflow.
+ ;; This environment variable is recommended in 'unix/Makefile'
+ ;; for passing flags to the C compiler.
+ (setenv "LOCAL_UNZIP" "-D_FORTIFY_SOURCE=1")
+ #t))
(replace 'build
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make"
@@ -1791,20 +1797,6 @@ recreates the stored directory structure by default.")
(license (license:non-copyleft "file://LICENSE"
"See LICENSE in the distribution."))))
-(define unzip/fixed
- (package/inherit unzip
- (arguments
- (substitute-keyword-arguments (package-arguments unzip)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'fortify
- (lambda _
- ;; Mitigate CVE-2018-1000035, an exploitable buffer overflow.
- ;; This environment variable is recommended in 'unix/Makefile'
- ;; for passing flags to the C compiler.
- (setenv "LOCAL_UNZIP" "-D_FORTIFY_SOURCE=1")
- #t))))))))
-
(define-public zziplib
(package
(name "zziplib")