summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 20:57:53 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit5257c341506c4d277b98e580a82857daafe073c7 (patch)
treea7e1726935a28d464a8608f2463d7100d6b3cdf3 /gnu/packages
parent31cac1ee9ffeae2974461a8864cb1112072f4744 (diff)
downloadpatches-5257c341506c4d277b98e580a82857daafe073c7.tar
patches-5257c341506c4d277b98e580a82857daafe073c7.tar.gz
gnu: Add ghc-temporary.
* gnu/packages/haskell.scm (ghc-temporary): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9d649da25d..8dd09ba642 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -964,6 +964,31 @@ but also need those types.")
for Haskell.")
(license bsd-3)))
+(define-public ghc-temporary
+ (package
+ (name "ghc-temporary")
+ (version "1.2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/temporary/temporary-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0is67bmsjmbbw6wymhis8wyq9gax3sszm573p5719fx2c9z9r24a"))))
+ (build-system haskell-build-system)
+ (propagated-inputs `(("ghc-exceptions" ,ghc-exceptions)))
+ (home-page "http://www.github.com/batterseapower/temporary")
+ (synopsis "Temporary file and directory support")
+ (description "The functions for creating temporary files and directories
+in the Haskelll base library are quite limited. This library just repackages
+the Cabal implementations of its own temporary file and folder functions so
+that you can use them without linking against Cabal or depending on it being
+installed.")
+ (license bsd-3)))
+
(define-public ghc-quickcheck-io
(package
(name "ghc-quickcheck-io")