summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-28 00:22:54 -0500
committerLeo Famulari <leo@famulari.name>2015-12-29 19:55:21 -0500
commit6819a8ddd64566d4e3b18f941bdbf23bac02caf1 (patch)
tree110078311a2444a97dac210ce153ead884e287d4 /gnu/packages
parent6da16993eb7c35d829e947d65e57508fa5d1a00f (diff)
downloadpatches-6819a8ddd64566d4e3b18f941bdbf23bac02caf1.tar
patches-6819a8ddd64566d4e3b18f941bdbf23bac02caf1.tar.gz
gnu: Add shntool.
* gnu/packages/audio.scm (shntool): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 652e229d9a..6af1144b7f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1986,3 +1986,23 @@ files are a way to represent the layout of a data or audio CD in a
machine-readable ASCII format.")
(home-page "https://github.com/svend/cuetools")
(license license:gpl2+)))
+
+(define-public shntool
+ (package
+ (name "shntool")
+ (version "3.0.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://etree.org/shnutils/shntool/dist/src/"
+ "shntool-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00i1rbjaaws3drkhiczaign3lnbhr161b7rbnjr8z83w8yn2wc3l"))))
+ (build-system gnu-build-system)
+ (synopsis "WAVE audio data processing tool")
+ (description "shntool is a multi-purpose WAVE data processing and reporting
+utility. File formats are abstracted from its core, so it can process any file
+that contains WAVE data, compressed or not---provided there exists a format
+module to handle that particular file type.")
+ (home-page "http://etree.org/shnutils/shntool/")
+ (license license:gpl3+)))