summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2015-11-12 01:19:44 +0800
committerLudovic Courtès <ludo@gnu.org>2015-12-30 18:18:38 +0100
commit0c1910ed036438adf7acaab0423cc85920eb66d9 (patch)
tree6aad46471333934e7982cbee9dc38c0522d3fef1 /gnu/packages
parent223d793903500f9e38ea9536a5b270ee7cf283f7 (diff)
downloadpatches-0c1910ed036438adf7acaab0423cc85920eb66d9.tar
patches-0c1910ed036438adf7acaab0423cc85920eb66d9.tar.gz
gnu: ladspa: Update URLs.
* gnu/packages/audio.scm (ladspa): Update source and home page url. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6af1144b7f..df1f67bddd 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -817,15 +817,20 @@ plugin function as a JACK application.")
(package
(name "ladspa")
(version "1.13")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.ladspa.org/download/ladspa_sdk_"
- version
- ".tgz"))
- (sha256
- (base32
- "0srh5n2l63354bc0srcrv58rzjkn4gv8qjqzg8dnq3rs4m7kzvdm"))))
+ (source
+ (origin
+ (method url-fetch)
+ ;; Since the official link is dead,
+ ;; we download the tarball from Debian or Internet Archive.
+ (uri (list (string-append "http://http.debian.net"
+ "/debian/pool/main/l/ladspa-sdk/ladspa-sdk_"
+ version ".orig.tar.gz")
+ (string-append "https://web.archive.org/web/20140717172251/"
+ "http://www.ladspa.org/download/ladspa_sdk_"
+ version ".tgz")))
+ (sha256
+ (base32
+ "0srh5n2l63354bc0srcrv58rzjkn4gv8qjqzg8dnq3rs4m7kzvdm"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; the "test" target is a listening test only
@@ -843,7 +848,9 @@ plugin function as a JACK application.")
(("^CC.*") "CC = gcc\n")
(("^CPP.*") "CPP = g++\n"))))
(alist-delete 'build %standard-phases))))
- (home-page "http://ladspa.org")
+ ;; Since the home page is gone, we provide a link to the archived version.
+ (home-page
+ "https://web.archive.org/web/20140729190945/http://www.ladspa.org/")
(synopsis "Linux Audio Developer's Simple Plugin API (LADSPA)")
(description
"LADSPA is a standard that allows software audio processors and effects