summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-29 15:13:52 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-01 10:31:04 +0100
commitd29150b55d4c0dcc371949d90d74b54d58bae098 (patch)
treec7401229cb6b32357bd1b25dc55c92f67ba03783 /gnu/packages
parentb4464d384c7a7b500e611ec257cf092cdc47d977 (diff)
downloadpatches-d29150b55d4c0dcc371949d90d74b54d58bae098.tar
patches-d29150b55d4c0dcc371949d90d74b54d58bae098.tar.gz
gnu: Add bwa-pssm.
* gnu/packages/bioinformatics.scm (bwa-pssm): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7b3838d36f..eef33dd42f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages cpio)
#:use-module (gnu packages curl)
#:use-module (gnu packages doxygen)
+ #:use-module (gnu packages datastructures)
#:use-module (gnu packages file)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gcc)
@@ -774,6 +775,35 @@ and more accurate. BWA-MEM also has better performance than BWA-backtrack for
70-100bp Illumina reads.")
(license license:gpl3+)))
+(define-public bwa-pssm
+ (package (inherit bwa)
+ (name "bwa-pssm")
+ (version "0.5.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/pkerpedjiev/bwa-pssm/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02p7mpbs4mlxmn84g2x4ghak638vbj4lqix2ipx5g84pz9bhdavg"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gdsl" ,gdsl)
+ ("zlib" ,zlib)
+ ("perl" ,perl)))
+ (home-page "http://bwa-pssm.binf.ku.dk/")
+ (synopsis "Burrows-Wheeler transform-based probabilistic short read mapper")
+ (description
+ "BWA-PSSM is a probabilistic short genomic sequence read aligner based on
+the use of @dfn{position specific scoring matrices} (PSSM). Like many of the
+existing aligners it is fast and sensitive. Unlike most other aligners,
+however, it is also adaptible in the sense that one can direct the alignment
+based on known biases within the data set. It is coded as a modification of
+the original BWA alignment program and shares the genome index structure as
+well as many of the command line options.")
+ (license license:gpl3+)))
+
(define-public python2-bx-python
(package
(name "python2-bx-python")