summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJesse Gibbons <jgibbons2357+guix@gmail.com>2019-11-16 18:33:05 -0700
committerLudovic Courtès <ludo@gnu.org>2019-11-17 23:14:54 +0100
commit6ba6a1c103ea94f2c9a984db466c3b2829e8f175 (patch)
tree307e3863d4f6b0351df18451fc6585d4c115224d /gnu/packages
parentea042113585d09bb9c12598f287a5a586a93a8cf (diff)
downloadpatches-6ba6a1c103ea94f2c9a984db466c3b2829e8f175.tar
patches-6ba6a1c103ea94f2c9a984db466c3b2829e8f175.tar.gz
gnu: python-hy: Set HOME to /tmp before install
Fixes <https://bugs.gnu.org/38241>. * gnu/packages/python-xyz.scm (python-hy)[arguments]: Add custom 'set-HOME phase before the 'install phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d2786e4826..5b8b33b87f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8745,6 +8745,9 @@ with a new public API, and RPython support.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-before 'install 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp")))
(replace 'check
(lambda _
;; Tests require write access to HOME.