summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-06 22:22:36 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-06 22:24:13 +0200
commit5d6c4d3794b8c77effcd9eeab22adc4e2c0d2c24 (patch)
tree7d1428ebb65b2b90304d8070260ac9a124ced06c /gnu/packages
parent8f03b70b020c5a4e3dfc3d515cdefbb7723e7fc9 (diff)
downloadpatches-5d6c4d3794b8c77effcd9eeab22adc4e2c0d2c24.tar
patches-5d6c4d3794b8c77effcd9eeab22adc4e2c0d2c24.tar.gz
gnu: commencement: Disable Texinfo tests during bootstrap.
* gnu/packages/commencement.scm (texinfo-boot0): Add #:tests? #f.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/commencement.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 6dfe5c9cb7..59a7c7798e 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -306,7 +306,12 @@
;; Also, use %BOOT0-INPUTS to avoid building Perl once more.
(let ((texinfo (package (inherit texinfo)
(native-inputs '())
- (inputs `(("perl" ,perl-boot0))))))
+ (inputs `(("perl" ,perl-boot0)))
+
+ ;; Some of Texinfo 6.1's tests would fail with "Couldn't
+ ;; set UTF-8 character type in locale" but we don't have a
+ ;; UTF-8 locale at this stage, so skip them.
+ (arguments '(#:tests? #f)))))
(package-with-bootstrap-guile
(package-with-explicit-inputs texinfo %boot0-inputs
(current-source-location)