summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-17 17:02:01 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-17 17:02:01 +0200
commit9f6065237d7be3672b9c48e0dfd89af85ff4eeec (patch)
tree98a4726654eb5820b7def484f4861ab071c5c840 /gnu/packages
parent1e1a65a63349d1d2bd272738304a1d9f3b128a84 (diff)
downloadpatches-9f6065237d7be3672b9c48e0dfd89af85ff4eeec.tar
patches-9f6065237d7be3672b9c48e0dfd89af85ff4eeec.tar.gz
gnu: Add edge-addition-planarity-suite.
* gnu/packages/maths.scm (edge-addition-planarity-suite): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6d8fb9cec5..b4e4067101 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015, 2016, 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2016, 2017 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
@@ -5003,3 +5003,31 @@ command-line tools, and an Application Programming Interface (API).
This package provides the static libraries required to run programs
compiled against the nauty library.")
(license license:asl2.0)))
+
+(define-public edge-addition-planarity-suite
+ (package
+ (name "edge-addition-planarity-suite")
+ (version "3.0.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/graph-algorithms/"
+ name))
+ (commit (string-append "Version_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01cm7ay1njkfsdnmnvh5zwc7wg7x189hq1vbfhh9p3ihrbnmqzh8"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (synopsis "Embedding of planar graphs")
+ (description "The package provides a reference implementation of the
+linear time edge addition algorithm for embedding planar graphs and
+isolating planarity obstructions.")
+ (license license:bsd-3)
+ (home-page
+ "https://github.com/graph-algorithms/edge-addition-planarity-suite")))