summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-17 17:37:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-17 17:37:04 +0200
commit7658904a34f0114ee5160be6ec4858fbec9dbe4c (patch)
tree11992e2acf7f575e777ad289f31a8edd2fe3d2dd /gnu/packages
parent9f6065237d7be3672b9c48e0dfd89af85ff4eeec (diff)
downloadpatches-7658904a34f0114ee5160be6ec4858fbec9dbe4c.tar
patches-7658904a34f0114ee5160be6ec4858fbec9dbe4c.tar.gz
gnu: Fix freeorion build.
* gnu/packages/games.scm (freeorion)[arguments]: Fix font unbundling.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index eed409135b..bf95bf735d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7492,9 +7492,9 @@ win.")
(let ((roboto-dir (string-append (assoc-ref inputs "font-roboto")
"/share/fonts/truetype/")))
(substitute* "UI/ClientUI.cpp"
- (("\\(GetRootDataDir.*?\"Roboto-(Bold|Regular)\\.ttf\"\\)\\.string\\(\\)\\);"
+ (("\\(GetRootDataDir.*?Roboto-(Bold|Regular)\\.ttf\"\\)\\.string\\(\\)\\);"
all type)
- (string-append "\"" roboto-dir "Roboto-" type "\");")))
+ (string-append "\"" roboto-dir "Roboto-" type ".ttf\");")))
#t))))))
(inputs
`(("boost" ,boost)