aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-08-06 18:37:17 +0800
committer宋文武 <iyzsong@gmail.com>2016-08-23 19:46:48 +0800
commit5613c27d9334a32911ad9731806be1ab9c4f6e1a (patch)
tree98cb9a61ea2af40296bd9ee623b2297e7bfa9cbf /gnu/packages
parent554b2dac09bef4dd0df4da6b869ebb4eb2ad2b55 (diff)
downloadpatches-5613c27d9334a32911ad9731806be1ab9c4f6e1a.tar
patches-5613c27d9334a32911ad9731806be1ab9c4f6e1a.tar.gz
gnu: gnome-icon-theme, adwaita-icon-theme: Don't install 'icon-theme.cache'.
* gnu/packages/gnome.scm (gnome-icon-theme)[native-inputs]: Remove 'gtk+'. [arguments]: Set 'GTK_UPDATE_ICON_CACHE' to the path of 'true'. (adwaita-icon-theme)[native-inputs]: Add 'gtk+:bin'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9462c702e4..1479885243 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -645,9 +645,14 @@ update-desktop-database: updates the database containing a cache of MIME types
(base32
"0fjh9qmmgj34zlgxb09231ld7khys562qxbpsjlaplq2j85p57im"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ ;; Don't create 'icon-theme.cache'.
+ (let* ((coreutils (assoc-ref %build-inputs "coreutils"))
+ (true (string-append coreutils "/bin/true")))
+ (list (string-append "GTK_UPDATE_ICON_CACHE=" true)))))
(native-inputs
- `(("gtk+" ,gtk+) ; for gtk-update-icon-cache
- ("icon-naming-utils" ,icon-naming-utils)
+ `(("icon-naming-utils" ,icon-naming-utils)
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(home-page "http://art.gnome.org/")
@@ -669,7 +674,9 @@ update-desktop-database: updates the database containing a cache of MIME types
name "-" version ".tar.xz"))
(sha256
(base32
- "0ddfwwqx8s63qbqimmbb015lqsab4s0rvy1j81jdsh7k95rqh2ks"))))))
+ "0ddfwwqx8s63qbqimmbb015lqsab4s0rvy1j81jdsh7k95rqh2ks"))))
+ (native-inputs
+ `(("gtk-encode-symbolic-svg" ,gtk+ "bin")))))
(define-public shared-mime-info
(package