summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-05-27 21:36:24 -0400
committerDavid Thompson <davet@gnu.org>2015-05-29 20:05:57 -0400
commitd4fde1f23914457ba01ae476bdff73dccbe38a34 (patch)
tree3029fb20d4bbb7364446f409d4f7e3d7951b1869 /gnu/packages
parent4f2a0cac7ff2b32cc3a024940dadcc32abab97e1 (diff)
downloadpatches-d4fde1f23914457ba01ae476bdff73dccbe38a34.tar
patches-d4fde1f23914457ba01ae476bdff73dccbe38a34.tar.gz
gnu: Add ruby-rspec.
* gnu/packages/ruby.scm (ruby-rspec): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d519ffc811..a738d3c471 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -289,3 +289,30 @@ outcomes of a code example.")
support for stubbing and mocking.")
(home-page "https://github.com/rspec/rspec-mocks")
(license license:expat)))
+
+(define-public ruby-rspec
+ (package
+ (name "ruby-rspec")
+ (version "3.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/rspec/rspec/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jg38dbaknsdhiav5vnrwfccg524fwcg6sq1715441vx1xl6p54q"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; avoid dependency cycles
+ (propagated-inputs
+ `(("ruby-rspec-core" ,ruby-rspec-core)
+ ("ruby-rspec-mocks" ,ruby-rspec-mocks)
+ ("ruby-rspec-expectations" ,ruby-rspec-expectations)))
+ (synopsis "Behavior-driven development framework for Ruby")
+ (description "RSpec is a behavior-driven development (BDD) framework for
+Ruby. This meta-package includes the RSpec test runner, along with the
+expectations and mocks frameworks.")
+ (home-page "http://rspec.info/")
+ (license license:expat)))