summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-21 16:24:55 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-22 15:23:23 +0200
commit748cef5be9c69978b5c70575340702d8df73f84a (patch)
tree2b4866bfcb862948c77a4289b0e0741dc651a873 /gnu/packages
parent5394a6a653e7338d73553eb77fa7c11c17562d3e (diff)
downloadpatches-748cef5be9c69978b5c70575340702d8df73f84a.tar
patches-748cef5be9c69978b5c70575340702d8df73f84a.tar.gz
gnu: Add python-rq.
* gnu/packages/python.scm (python-rq, python2-rq): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 99c20ef07d..9da91111f6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2197,6 +2197,35 @@ mining and data analysis.")
(define-public python2-redis
(package-with-python2 python-redis))
+(define-public python-rq
+ (package
+ (name "python-rq")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/r/rq/rq-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0b0z5hn8wkfg300hx7816csgv3bcfamlr29fi3yzgqmpqxwj3fix"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-click" ,python-click)
+ ("python-redis" ,python-redis)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://python-rq.org/")
+ (synopsis "Simple job queues for Python")
+ (description
+ "RQ (Redis Queue) is a simple Python library for queueing jobs and
+processing them in the background with workers. It is backed by Redis and it
+is designed to have a low barrier to entry.")
+ (license bsd-2)))
+
+(define-public python2-rq
+ (package-with-python2 python-rq))
+
(define-public python-cython
(package
(name "python-cython")