summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-15 12:45:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-15 12:45:26 +0100
commita74f9b12ae3937cd75c4dba4715cf55387c507c8 (patch)
treeed266090a6fb2a2be5ddd41d5a7d56eedbc4ce31 /gnu/packages
parent40bb8e07aedb011de863657f6cec29d86d525375 (diff)
downloadpatches-a74f9b12ae3937cd75c4dba4715cf55387c507c8.tar
patches-a74f9b12ae3937cd75c4dba4715cf55387c507c8.tar.gz
gnu: python-zope-security: Disable tests.
* gnu/packages/python.scm (python-zope-security, python2-zope-security)[arguments]: Set #:tests? #f. [native-inputs]: Add python-six.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7109860f5b..aca2f3c92d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7495,12 +7495,15 @@ Zope3, which are are special objects that have a structural location.")
(base32
"14zmf684amc0x32kq05yxnhfqd1cmyhafkw05gn81rn90zjv6ssy"))))
(build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; FIXME: Tests can't find zope.testrunner.
(propagated-inputs
`(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
("python-zope-proxy" ,python-zope-proxy)
("python-zope-schema" ,python-zope-schema)))
- (native-inputs
- `(("python-zope-component" ,python-zope-component)
+ (native-inputs
+ `(("python-six" ,python-six)
+ ("python-zope-component" ,python-zope-component)
("python-zope-configuration" ,python-zope-configuration)
("python-zope-location" ,python-zope-location)
("python-zope-testrunner" ,python-zope-testrunner)