summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-02 21:48:50 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-02 21:48:50 +0200
commitb24d1cfc85cba1024d7396f3ad625c5fc3cf926b (patch)
treeaae36e56660290c87e6e2de3e57254479cfffe66 /gnu/packages
parentfbc1a58f4071c8a3ce2ac781b7cd363b8d21a364 (diff)
downloadpatches-b24d1cfc85cba1024d7396f3ad625c5fc3cf926b.tar
patches-b24d1cfc85cba1024d7396f3ad625c5fc3cf926b.tar.gz
gnu: python: Revert 77c7f8f4 and make Python 3 the default.
* gnu/packages/python.scm (python-3): Rename this to... * gnu/packages/python.scm (python): ...this, rename this to... * gnu/packages/python.scm (python-2): ...this.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 493068adde..0a3977aabb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -31,7 +31,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python))
-(define-public python
+(define-public python-2
(package
(name "python")
(version "2.7.5")
@@ -151,8 +151,8 @@ packages; exception-based error handling; and very high level dynamic
data types.")
(license psfl)))
-(define-public python-3
- (package (inherit python)
+(define-public python
+ (package (inherit python-2)
(version "3.3.2")
(source
(origin