summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-04 22:12:33 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-04 22:12:33 +0200
commit89114f39e4be7ac655fbdd7f00a5f985c8f4ce6b (patch)
treea29d8e019d026bfda2ee6824ddc742eb2b60b917 /gnu/packages
parentaa9e22efa38a88c2370591a3656b23f52d3bab64 (diff)
downloadpatches-89114f39e4be7ac655fbdd7f00a5f985c8f4ce6b.tar
patches-89114f39e4be7ac655fbdd7f00a5f985c8f4ce6b.tar.gz
gnu: python: Implement the python naming scheme for pytz and babel.
* gnu/packages/python.scm (pytz): Rename this ... * gnu/packages/python.scm (python-pytz): ... to this * gnu/packages/python.scm (python2-pytz): New variable, input python-2. * gnu/packages/python.scm (babel): Rename this ... * gnu/packages/python.scm (python-babel): ... to this * gnu/packages/python.scm (python2-babel): New variable, input python-2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 33082a6d94..a4007d963b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -193,9 +193,9 @@ data types.")
without version suffix."))))
-(define-public pytz
+(define-public python-pytz
(package
- (name "pytz")
+ (name "python-pytz")
(version "2013b")
(source
(origin
@@ -213,9 +213,14 @@ data types.")
using Python 2.4 or higher and provides access to the Olson timezone database.")
(license x11)))
-(define-public babel
+(define-public python2-pytz
+ (package (inherit python-pytz)
+ (name "python2-pytz")
+ (arguments `(#:python ,python-2))))
+
+(define-public python-babel
(package
- (name "babel")
+ (name "python-babel")
(version "0.9.6")
(source
(origin
@@ -227,7 +232,7 @@ using Python 2.4 or higher and provides access to the Olson timezone database.")
"03vmr54jq5vf3qw6kpdv7cdk7x7i2jhzyf1mawv2gk8zrxg0hfja"))))
(build-system python-build-system)
(inputs
- `(("pytz" ,pytz)))
+ `(("python-pytz" ,python-pytz)))
(home-page "http://babel.edgewall.org/")
(synopsis
"Tools for internationalizing Python applications")
@@ -238,3 +243,10 @@ using Python 2.4 or higher and provides access to the Olson timezone database.")
access to various locale display names, localized number and date formatting,
etc. ")
(license bsd-3)))
+
+(define-public python2-babel
+ (package (inherit python-babel)
+ (name "python2-babel")
+ (inputs
+ `(("python2-pytz" ,python2-pytz)))
+ (arguments `(#:python ,python-2))))