summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-02 14:47:26 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-02 15:00:48 +0100
commit02267798de00870a3bcfa8d6c528bb06380b4b5e (patch)
tree93bc3fb5cbb1beaffeedbab9c07436dd1224416c /gnu/packages
parent7502badb81311df8ded0202c99b7cada31511678 (diff)
downloadpatches-02267798de00870a3bcfa8d6c528bb06380b4b5e.tar
patches-02267798de00870a3bcfa8d6c528bb06380b4b5e.tar.gz
gnu: Add emacs-org-tree-slide.
Thanks, Pjotr & Ricardo! :-) * gnu/packages/emacs.scm (org-tree-slide): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9be92edc10..d2c81736bd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -6918,3 +6918,25 @@ supports multiple backends such as @code{vlc}, @code{mpg123},
Groovy source files, REPL integration with run-groovy and Grails project
navigation with the grails mode.")
(license license:gpl3+)))
+
+(define-public org-tree-slide
+ (let ((commit "dff8f1a4a64c8dd0a1fde0b0131e2fe186747134")
+ (revision "0"))
+ (package
+ (name "emacs-org-tree-slide")
+ (version (git-version "0.1" revision commit))
+ (home-page "https://github.com/takaxp/org-tree-slide")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (sha256
+ (base32
+ "153bg0x7ypla11pq51jmsgzfjklwwnrq56xgpbfhk1j16xwz9hyf"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (synopsis "Presentation tool for org-mode")
+ (description
+ "Org-tree-slide provides a slideshow mode to view org-mode files. Use
+@code{org-tree-slide-mode} to enter the slideshow mode, and then @kbd{C->} and
+@kbd{C-<} to jump to the next and previous slide.")
+ (license license:gpl3+))))