summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-11 17:52:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-11 19:55:39 +0200
commit251448f7f54a3fbc458ac57a0a7e6c3c4a7ad816 (patch)
tree91d1bcc49ef1a10bbd8c4889225d2810cbedea25 /gnu/packages
parentb421e9155800d70d995591e4a63f92561714301c (diff)
downloadpatches-251448f7f54a3fbc458ac57a0a7e6c3c4a7ad816.tar
patches-251448f7f54a3fbc458ac57a0a7e6c3c4a7ad816.tar.gz
gnu: picard: Use build system features.
* gnu/packages/music.scm (picard)[arguments]: Leverage #:use-setuptools? and #:configure-flags instead of a custom ‘install’ phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 49e29340a6..796b74816c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2556,7 +2556,10 @@ event-based scripts for scrobbling, notifications, etc.")
"19w5k3bf4886gdycxjds9nkjvir0gwy2r5cqkz0lbls4ikk4y14f"))))
(build-system python-build-system)
(arguments
- '(#:phases
+ '(#:use-setuptools? #f
+ #:configure-flags
+ (list "--root=/")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
(lambda* (#:key inputs #:allow-other-keys)
@@ -2564,12 +2567,7 @@ event-based scripts for scrobbling, notifications, etc.")
(("pyfpcalc")
(string-append
"pyfpcalc', '"
- (assoc-ref inputs "chromaprint") "/bin/fpcalc")))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "python" "setup.py" "install"
- (string-append "--prefix=" (assoc-ref outputs "out"))
- "--root=/"))))))
+ (assoc-ref inputs "chromaprint") "/bin/fpcalc"))))))))
(native-inputs
`(("gettext" ,gettext-minimal)))
(inputs