summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 00:16:16 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:45 +0100
commit4f0b3368ad78f584239c4fcf97d2ed1737dba332 (patch)
treecbd4fc054c6bebbc6e46108f9577ead97886a185 /gnu/packages
parent69436285bd014ccebfb499d7eec6a2c6f1e7d13f (diff)
downloadpatches-4f0b3368ad78f584239c4fcf97d2ed1737dba332.tar
patches-4f0b3368ad78f584239c4fcf97d2ed1737dba332.tar.gz
gnu: Add granatier.
* gnu/packages/games.scm (granatier): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d8329c557b..cdec72ab0e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8766,3 +8766,42 @@ not destroyed a building in your path, you will crash into it.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public granatier
+ (package
+ (name "granatier")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/granatier-" version ".tar.xz"))
+ (sha256
+ (base32 "141qmdinz7ikbbrs8dq6cap3nl22sl7pw62r80pf3xxwn2q4phpa"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("knewstuff" ,knewstuff)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Bomberman clone")
+ (description "Granatier is a clone of the classic Bomberman game,
+inspired by the work of the Clanbomber clone.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))