summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-26 23:04:53 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-26 23:34:59 +0200
commit1e8439de270c768a24ae9d65f329a1eae2ea480f (patch)
tree9601055b226f0210ed05d11a19ef256d32189ca2 /gnu/packages
parentacb98ad95603cd81040446d394d4ee5a80b5c463 (diff)
downloadpatches-1e8439de270c768a24ae9d65f329a1eae2ea480f.tar
patches-1e8439de270c768a24ae9d65f329a1eae2ea480f.tar.gz
gnu: ocaml-pcre: Update to 7.4.1.
* gnu/packages/ocaml.scm (ocaml-pcre): Update to 7.4.1. [build-system]: Use dune-build-system. [source]: Use git-fetch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 10 insertions, 20 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8a229d083b..6e4338182d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2323,31 +2323,21 @@ hierarchy of modules.")
(define-public ocaml-pcre
(package
(name "ocaml-pcre")
- (version "7.2.3")
+ (version "7.4.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mmottl/pcre-ocaml/archive"
- "/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mmottl/pcre-ocaml")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0rj6dw79px4sj2kq0iss2nzq3rnsn9wivvc0f44wa1mppr6njfb3"))))
- (build-system ocaml-build-system)
+ "11sd8g668h48790lamz0riw9jgnfkaif5qdfa0akcndwa6aj07jf"))))
+ (build-system dune-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'link-lib
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (stubs (string-append out "/lib/ocaml/site-lib/stubslibs"))
- (lib (string-append out "/lib/ocaml/site-lib/pcre")))
- (mkdir-p stubs)
- (symlink (string-append lib "/dllpcre_stubs.so")
- (string-append stubs "/dllpcre_stubs.so")))
- #t)))))
+ `(#:test-target "."))
(native-inputs
- `(("batteries" ,ocaml-batteries)
- ("ocamlbuild" ,ocamlbuild)
+ `(("ocaml-base" ,ocaml-base)
("pcre:bin" ,pcre "bin")))
(propagated-inputs `(("pcre" ,pcre)))
(home-page "https://mmottl.github.io/pcre-ocaml")