summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-24 20:16:11 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-25 14:06:38 +0100
commit4ad7d037ad373a46e341354b19f0b17c737beebb (patch)
tree8ca883c774ebd3dd91a0b4f1dfcb1a3032baf609 /gnu/packages
parentbd414e273c2010132895a645b623035c218eb437 (diff)
downloadpatches-4ad7d037ad373a46e341354b19f0b17c737beebb.tar
patches-4ad7d037ad373a46e341354b19f0b17c737beebb.tar.gz
gnu: Add ghc-libmpd.
* gnu/packages/haskell.scm (ghc-libmpd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b8ea36852b..255e902e66 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11461,4 +11461,36 @@ foreign imports by hand (or using hsc2hs), this ensures that C functions are
imported with the correct Haskell types.")
(license license:gpl2)))
+(define-public ghc-libmpd
+ (package
+ (name "ghc-libmpd")
+ (version "0.9.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/libmpd/libmpd-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1931m23iqb4wddpdidm4ph746zpaw41kkjzmb074j7yyfpk7x1jv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-text" ,ghc-text)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-network" ,ghc-network)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/vimus/libmpd-haskell")
+ (synopsis "Haskell client library for the Music Player Daemon")
+ (description "This package provides a pure Haskell client library for the
+Music Player Daemon.")
+ (license license:expat)))
+
;;; haskell.scm ends here