summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDan Frumin <dfrumin@cs.ru.nl>2019-06-08 15:30:33 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-19 22:56:28 +0200
commit3f9a027ce2016fdde41355f98ce44e66a2bb7980 (patch)
tree3e850d507972a0fb6273487072ffb480022c84db /gnu/packages
parent8785a71faf45253819cb4fec9cb7e0155b18ceb0 (diff)
downloadpatches-3f9a027ce2016fdde41355f98ce44e66a2bb7980.tar
patches-3f9a027ce2016fdde41355f98ce44e66a2bb7980.tar.gz
gnu: Add crispy-doom.
* gnu/packages/games.scm (crispy-doom): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index bf95bf735d..bf3ab94e68 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2019 Dan Frumin <dfrumin@cs.ru.nl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5596,6 +5597,40 @@ affect gameplay).")
(home-page "https://www.chocolate-doom.org/wiki/index.php/Chocolate_Doom")
(license license:gpl2)))
+(define-public crispy-doom
+ (package
+ (inherit chocolate-doom)
+ (name "crispy-doom")
+ (version "5.5.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fabiangreffrath/crispy-doom.git")
+ (commit (string-append "crispy-doom-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a60ns0blhvml6gzj9qx18c18pbf02rq7vypaajd6nqy5h4fz3cn"))))
+ (native-inputs
+ (append
+ (package-native-inputs chocolate-doom)
+ `(("automake" ,automake)
+ ("autoreconf" ,autoconf))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ ;; the autogen.sh script in the source tree doesn't work
+ (lambda _ (invoke "autoreconf" "-vif"))))))
+ (synopsis "Limit-removing enhanced-resolution Doom source port based on
+Chocolate Doom")
+ (description
+ "Crispy Doom is a friendly fork of Chocolate Doom that provides a higher
+display resolution, removes the static limits of the Doom engine and offers
+further optional visual, tactical and physical enhancements while remaining
+entirely config file, savegame, netplay and demo compatible with the
+original.")
+ (home-page "https://www.chocolate-doom.org/wiki/index.php/Crispy_Doom")))
+
(define-public fortune-mod
(package
(name "fortune-mod")