summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-26 19:46:48 -0500
committerLeo Famulari <leo@famulari.name>2017-02-27 04:04:51 -0500
commit1d8e7273578e95f6b5e4293ac34c4f6fe5d5c579 (patch)
treeb369e88eb734539e2b2e4d92e779ac0217542c40 /gnu/packages
parentc1ed10f95e81ee1f2c6d242164fdcb6d9dfad9f3 (diff)
downloadpatches-1d8e7273578e95f6b5e4293ac34c4f6fe5d5c579.tar
patches-1d8e7273578e95f6b5e4293ac34c4f6fe5d5c579.tar.gz
gnu: gst-plugins-base: Update to 1.10.4.
* gnu/packages/gstreamer.scm (gst-plugins-base): Update to 1.10.4. [source]: Remove obsolete patch 'gst-plugins-base-fix-test-on-32bit.patch' * gnu/packages/patches/gst-plugins-base-fix-test-on-32bit.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gstreamer.scm10
-rw-r--r--gnu/packages/patches/gst-plugins-base-fix-test-on-32bit.patch32
2 files changed, 6 insertions, 36 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index d81aad6f88..025f665782 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -146,7 +146,7 @@ This package provides the core library and elements.")
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
- (version "1.10.3")
+ (version "1.10.4")
(source
(origin
(method url-fetch)
@@ -154,9 +154,11 @@ This package provides the core library and elements.")
name "-" version ".tar.xz"))
(sha256
(base32
- "040pifl4cgsqqz2si4s1y5khj3zwm39w21siagxwp805swbrcag6"))
- (patches
- (search-patches "gst-plugins-base-fix-test-on-32bit.patch"))))
+ "1dsyjf6rncsbg4rfj40cvf1wwpjj9h3j3c7bh4zp7jylnfv4blpn"))
+; (patches
+; (search-patches "gst-plugins-base-fix-test-on-32bit.patch"))
+
+ ))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
diff --git a/gnu/packages/patches/gst-plugins-base-fix-test-on-32bit.patch b/gnu/packages/patches/gst-plugins-base-fix-test-on-32bit.patch
deleted file mode 100644
index 4c6c7ed06e..0000000000
--- a/gnu/packages/patches/gst-plugins-base-fix-test-on-32bit.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-This fixes a test failure on i686.
-
-Patch copied from upstream source repository:
-
-https://cgit.freedesktop.org/gstreamer/gst-plugins-base/commit/?id=5e2e111627871c566ffc6607eda8f4ef4699d040
-
-From 5e2e111627871c566ffc6607eda8f4ef4699d040 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
-Date: Thu, 2 Feb 2017 14:56:39 +0200
-Subject: [PATCH] multifdsink: Make sure to use a 64 bit integer for the
- units-max property
-
----
- tests/check/elements/multifdsink.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/check/elements/multifdsink.c b/tests/check/elements/multifdsink.c
-index af138cc92..951b1b9fa 100644
---- a/tests/check/elements/multifdsink.c
-+++ b/tests/check/elements/multifdsink.c
-@@ -869,7 +869,7 @@ GST_START_TEST (test_client_kick)
- gint i, initial_buffers = 3, num_buffers = 0;
-
- sink = setup_multifdsink ();
-- g_object_set (sink, "units-max", initial_buffers, NULL);
-+ g_object_set (sink, "units-max", (gint64) initial_buffers, NULL);
-
- fail_if (pipe (pfd1) == -1);
- fail_if (pipe (pfd2) == -1);
---
-2.11.0
-