summaryrefslogtreecommitdiff
path: root/gnu/packages/zip.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-10-08 10:01:02 -0400
committerMark H Weaver <mhw@netris.org>2015-10-08 10:07:44 -0400
commit48e4a9f32f93c404b6fb4472164d8e00d12b2937 (patch)
tree8057d803846a751ff0a2beef9f66b45d8f9a0765 /gnu/packages/zip.scm
parente91e28d60c66362b7114d7a3ed7809609f2c1b4b (diff)
downloadpatches-48e4a9f32f93c404b6fb4472164d8e00d12b2937.tar
patches-48e4a9f32f93c404b6fb4472164d8e00d12b2937.tar.gz
gnu: unzip: Add various fixes.
* gnu/packages/patches/unzip-increase-size-of-cfactorstr.patch: Delete file. Replace with ... * gnu/packages/patches/unzip-overflow-long-fsize.patch: ... this new file. * gnu/packages/patches/unzip-attribs-overflow.patch, gnu/packages/patches/unzip-fix-overflows-and-infloop.patch, gnu/packages/patches/unzip-format-secure.patch: New files. * gnu/packages/patches/unzip-CVE-2014-9636.patch: Replace contents with fixed patch from Fedora. * gnu-system.am (dist_patch_DATA): Adjust accordingly. * gnu/packages/zip.scm (unzip)[source]: Adjust list of patches.
Diffstat (limited to 'gnu/packages/zip.scm')
-rw-r--r--gnu/packages/zip.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/zip.scm b/gnu/packages/zip.scm
index f0f27ddfe2..83c452778c 100644
--- a/gnu/packages/zip.scm
+++ b/gnu/packages/zip.scm
@@ -86,9 +86,12 @@ Compression ratios of 2:1 to 3:1 are common for text files.")
"unzip-CVE-2014-8141.patch"
"unzip-CVE-2014-9636.patch"
"unzip-allow-greater-hostver-values.patch"
- "unzip-increase-size-of-cfactorstr.patch"
"unzip-initialize-symlink-flag.patch"
- "unzip-remove-build-date.patch")))))
+ "unzip-remove-build-date.patch"
+ "unzip-attribs-overflow.patch"
+ "unzip-fix-overflows-and-infloop.patch"
+ "unzip-format-secure.patch"
+ "unzip-overflow-long-fsize.patch")))))
(build-system gnu-build-system)
;; no inputs; bzip2 is not supported, since not compiled with BZ_NO_STDIO
(arguments