summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-11-25 15:13:08 +0100
committerJohn Darrington <jmd@gnu.org>2016-11-28 18:22:15 +0100
commitf0ddc5e55b0a022a2c7478efa791c5ae03ea8010 (patch)
treec3a760dd55ad0e764f7ccc6a4b50d008e344b66e /gnu/packages/xorg.scm
parent9926875572cf2936b7f23fb291328bfa68c038c6 (diff)
downloadpatches-f0ddc5e55b0a022a2c7478efa791c5ae03ea8010.tar
patches-f0ddc5e55b0a022a2c7478efa791c5ae03ea8010.tar.gz
gnu: Add editres.
* gnu/packages/xorg.scm (editres): New variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 9f9549b6b9..4e79d2d132 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -335,6 +336,44 @@ provided.")
"See 'dri3proto.h' in the distribution."))))
+(define-public editres
+ (package
+ (name "editres")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/app/" name "-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "1w2d5hb5pw9ii2jlf4yjlp899402zfwc8hdkpdr3i1fy1cjd2riv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-appdefaultdir="
+ %output "/lib/X11/app-defaults"))))
+ (inputs
+ `(("libxaw" ,libxaw)
+ ("libxmu" ,libxmu)
+ ("libxt" ,libxt)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.x.org/wiki/")
+ (synopsis "Tool to browse and edit X Toolkit resource specifications")
+ (description
+ "Editres is a tool that allows users and application developers to view
+the full widget hierarchy of any X Toolkit application that speaks the Editres
+protocol. In addition, editres will help the user construct resource
+specifications, allow the user to apply the resource to the application and
+view the results dynamically. Once the user is happy with a resource
+specification editres will append the resource string to the user's X
+Resources file.")
+ (license license:x11)))
+
+
(define-public encodings
(package
(name "encodings")