summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-14 19:37:52 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-14 19:39:29 +0100
commited824a36c453c31118bb54e4d4349e5dc6907b83 (patch)
tree22ba6df9e5f98be184414a245cada9ae37a4d884 /gnu/packages/xorg.scm
parent58d222ed0b1f905aca2212a3ca892aa7ae2a78e6 (diff)
downloadpatches-ed824a36c453c31118bb54e4d4349e5dc6907b83.tar
patches-ed824a36c453c31118bb54e4d4349e5dc6907b83.tar.gz
gnu: xorg: Make font packages bit-reproducible.
* gnu/packages/xorg.scm (%xorg-font-origin): Add 'snippet' and 'modules' fields.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index bbd02030ad..b780d47c32 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -404,7 +404,14 @@ Resources file.")
(method url-fetch)
(uri (string-append "mirror://xorg/individual/font/" font "-"
version ".tar.bz2"))
- (sha256 hash)))
+ (sha256 hash)
+ (modules '((guix build utils)))
+ (snippet
+ ;; Do not include timestamps in '.pcf.gz' files.
+ '(substitute* "Makefile.in"
+ (("^COMPRESS = (.*)$" _ rest)
+ (string-append "COMPRESS = " (string-trim-right rest)
+ " --no-name\n"))))))
(define-syntax-rule (xorg-font-origin font version hash)
"Expand to the 'origin' form for the given Xorg font package."