summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 21:26:54 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:18 -0500
commitbd6863c24546826a693359624827627f4d754322 (patch)
tree5f04fb972b494ba1a374dcc9041a2e5eea0b2dc6 /gnu/packages/xorg.scm
parent7dd17c76ae88ad2abcb215312b7e03311dc67c68 (diff)
downloadpatches-bd6863c24546826a693359624827627f4d754322.tar
patches-bd6863c24546826a693359624827627f4d754322.tar.gz
gnu: xf86-video-vmware: Update to 13.0.2.
* gnu/packages/patches/xf86-video-vmware-glibc-2.20.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-video-vmware): Update to 13.0.2. Add patch. Add mesa to inputs.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 1ec6257c8d..743b178208 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3050,20 +3050,22 @@ kernel mode setting (KMS).")
(define-public xf86-video-vmware
(package
(name "xf86-video-vmware")
- (version "12.0.2")
+ (version "13.0.2")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/X11R7.7/src/everything/xf86-video-vmware-"
+ "mirror://xorg/individual/driver/xf86-video-vmware-"
version
".tar.bz2"))
(sha256
(base32
- "0isiwx516gww8hfk3vy7js83yziyjym9mq2zjadyq1a8v5gqf9y8"))))
+ "0m1wfsv34s4pyr5ry87yyjb2p6vmy6vyypdz5jx0sqnkx8n3vfn8"))
+ (patches (list (search-patch "xf86-video-vmware-glibc-2.20.patch")))))
(build-system gnu-build-system)
(inputs `(("libx11" ,libx11)
("libxext" ,libxext)
+ ("mesa" ,mesa) ; for xatracker
("xorg-server" ,xorg-server)))
(native-inputs
`(("pkg-config" ,pkg-config)))