summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-02 22:42:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:03 +0100
commitbadcb119c57fe1a6fc617d2f4a237c1192305584 (patch)
tree58865d508be43eece23b99c0461a13fc032053f1 /gnu/packages/xml.scm
parent066398768de6d0ed833970832bc5e5f88677416e (diff)
downloadpatches-badcb119c57fe1a6fc617d2f4a237c1192305584.tar
patches-badcb119c57fe1a6fc617d2f4a237c1192305584.tar.gz
gnu: libxslt: Update to 1.1.34.
* gnu/packages/xml.scm (libxslt): Update to 1.1.34. [arguments]: Add phase to disable fuzz tests. * gnu/packages/patches/libxslt-generated-ids.patch: Adjust for upstream changes.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d1376a5bee..84066ff5d1 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -212,16 +212,26 @@ project (but it is usable outside of the Gnome platform).")
(define-public libxslt
(package
(name "libxslt")
- (version "1.1.33")
+ (version "1.1.34")
(source (origin
(method url-fetch)
(uri (string-append "ftp://xmlsoft.org/libxslt/libxslt-"
version ".tar.gz"))
(sha256
(base32
- "1j1q1swnsy8jgi9x7mclvkrqhfgn09886gdlr9wzk7a08i8n0dlf"))
+ "0zrzz6kjdyavspzik6fbkpvfpbd25r2qg6py5nnjaabrsr3bvccq"))
(patches (search-patches "libxslt-generated-ids.patch"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-fuzz-tests
+ (lambda _
+ ;; Disable libFuzzer tests, because they require
+ ;; instrumentation builds of libxml2 and libxslt.
+ (substitute* "tests/Makefile"
+ (("exslt plugins fuzz")
+ "exslt plugins"))
+ #t)))))
(home-page "http://xmlsoft.org/XSLT/index.html")
(synopsis "C library for applying XSLT stylesheets to XML documents")
(inputs `(("libgcrypt" ,libgcrypt)