summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-31 13:47:46 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-31 13:47:46 +0200
commit37f9ff639ebbbcd3cfeac619282b1f8f8a672cf8 (patch)
tree42adddc495097f00ebb55f19a93982ee187b0c4a /gnu/packages/xml.scm
parent24b5c463f3b70e2d2da1219bf32db28f5bb4582c (diff)
downloadpatches-37f9ff639ebbbcd3cfeac619282b1f8f8a672cf8.tar
patches-37f9ff639ebbbcd3cfeac619282b1f8f8a672cf8.tar.gz
gnu: Add xmlto.
* gnu/packages/xml.scm (xmlto): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 6edff473da..2f9d64b81a 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -28,7 +28,8 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system perl))
+ #:use-module (guix build-system perl)
+ #:use-module (gnu packages linux))
(define-public expat
(package
@@ -138,3 +139,27 @@ then passed on to the Expat object on each parse call. They can also be given
as extra arguments to the parse methods, in which case they override options
given at XML::Parser creation time.")
(home-page "http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm")))
+
+(define-public xmlto
+ (package
+ (name "xmlto")
+ (version "0.0.25")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://fedorahosted.org/releases/x/m/xmlto/xmlto-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0dp5nxq491gymq806za0dk4hngfmq65ysrqbn0ypajqbbl6vf71n"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("util-linux" ,util-linux)))
+ (home-page "http://cyberelk.net/tim/software/xmlto/")
+ (synopsis "Front-end to an XSL toolchain")
+ (description
+ "Xmlto is a front-end to an XSL toolchain. It chooses an appropriate
+stylesheet for the conversion you want and applies it using an external
+XSL-T processor. It also performs any necessary post-processing.")
+ (license license:gpl2+)))