summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-02-10 18:35:02 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:04:29 +0100
commita5ec8a5c6b2e78f3f5fdde7294cd68cdd17cbe5e (patch)
treec7047dadaeef1981faded4e259519684fca417b8 /gnu/packages/xml.scm
parentb8798817a18c51d372b4207fcb8fd5f2d6723dc7 (diff)
downloadpatches-a5ec8a5c6b2e78f3f5fdde7294cd68cdd17cbe5e.tar
patches-a5ec8a5c6b2e78f3f5fdde7294cd68cdd17cbe5e.tar.gz
gnu: Add java-jdom2.
* gnu/packages/xml.scm (java-jdom2): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 76e44157b9..758c6d308d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1929,3 +1929,28 @@ vice-versa with the help of the @dfn{Streaming API for XML} (StAX). It
implements @code{XMLStreamWriter} and @code{XMLStreamReader} and supports
@code{Mapped} and @code{BadgerFish} conventions.")
(license license:asl2.0)))
+
+(define-public java-jdom2
+ (package
+ (name "java-jdom")
+ (version "2.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/hunterhacker/jdom/archive/JDOM-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0p8n7inqq2a25wk9ljinl3ixlx1x2la9qaman8ngd75xxjb02yc1"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:build-target "package"
+ #:tests? #f; tests are run as part of the build process
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (install-jars "build")))))
+ (home-page "http://jdom.org/")
+ (synopsis "Access, manipulate, and output XML data")
+ (description "Jdom is a Java-based solution for accessing, manipulating, and
+outputting XML data from Java code.")
+ (license license:bsd-4)))