summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-02-10 18:02:31 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:04:16 +0100
commit9421f682244d5e8b1dcb17a042b38c0c83fc43d8 (patch)
tree3f202d57fc2bddd7082ca65e2c9fee26333d0705 /gnu/packages/xml.scm
parent82d7d4e1c81744f49f3b2168774437532755b32d (diff)
downloadpatches-9421f682244d5e8b1dcb17a042b38c0c83fc43d8.tar
patches-9421f682244d5e8b1dcb17a042b38c0c83fc43d8.tar.gz
gnu: Add java-xmlpull2.
* gnu/packages/xml.scm (java-xmlpull2): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index e65ea53f3e..af2097a70d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1719,3 +1719,34 @@ package is a stable XmlPull parsing engine that is based on ideas from XPP
and in particular XPP2 but completely revised and rewritten to take the best
advantage of JIT JVMs.")
(license (license:non-copyleft "file://LICENSE.txt"))))
+
+(define-public java-xmlpull2
+ (package
+ (name "java-xmlpull2")
+ (version "2.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.extreme.indiana.edu/xgws/xsoap/"
+ "PullParser/PullParser" version ".tgz"))
+ (sha256
+ (base32
+ "1kw9nhyqb7bzhn2zjbwlpi5vp5rzj89amzi3hadw2acyh2dmd0md"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin ;; Delete bundled jar archives.
+ (for-each delete-file (find-files "." ".*\\.jar"))
+ #t))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f; no tests
+ #:build-target "impl"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install (install-jars "build/lib")))))
+ (home-page "http://www.extreme.indiana.edu/xgws/xsoap/xpp/")
+ (synopsis "Streaming pull XML parser")
+ (description "Xml Pull Parser (in short XPP) is a streaming pull XML
+parser and should be used when there is a need to process quickly and
+efficiently all input elements (for example in SOAP processors). This
+package is in maintenance mode.")
+ (license (license:non-copyleft "file:///LICENSE.txt"))))