summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-25 12:45:24 -0500
committerLeo Famulari <leo@famulari.name>2017-01-25 13:23:21 -0500
commite9f62e527e3fdf953ff4884ed1973eec6900c8ee (patch)
tree903d8d5c139815f78e11b0c29a393725ab8bc51c /gnu/packages/xml.scm
parentd123f2f991e0bf6f51e5f207d291fb4c1ceb1245 (diff)
downloadpatches-e9f62e527e3fdf953ff4884ed1973eec6900c8ee.tar
patches-e9f62e527e3fdf953ff4884ed1973eec6900c8ee.tar.gz
gnu: libxml2: Incorporate grafted patches.
* gnu/packages/xml.scm (libxml2)[replacement]: Remove field. [source]: Add patches 'libxml2-CVE-2016-4658.patch' and 'libxml2-CVE-2016-5131.patch'. (python-libxml2)[replacement]: Remove field. (libxml2/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 32b658489c..d16821f228 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Raimon Grau <raimonster@gmail.com>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
@@ -74,12 +74,13 @@ things the parser might find in the XML document (like start tags).")
(define-public libxml2
(package
(name "libxml2")
- (replacement libxml2/fixed)
(version "2.9.4")
(source (origin
(method url-fetch)
(uri (string-append "ftp://xmlsoft.org/libxml2/libxml2-"
version ".tar.gz"))
+ (patches (search-patches "libxml2-CVE-2016-4658.patch"
+ "libxml2-CVE-2016-5131.patch"))
(sha256
(base32
"0g336cr0bw6dax1q48bblphmchgihx9p1pjmxdnrd6sh3qci3fgz"))))
@@ -102,19 +103,9 @@ things the parser might find in the XML document (like start tags).")
project (but it is usable outside of the Gnome platform).")
(license license:x11)))
-(define libxml2/fixed
- (package
- (inherit libxml2)
- (source
- (origin
- (inherit (package-source libxml2))
- (patches (search-patches "libxml2-CVE-2016-4658.patch"
- "libxml2-CVE-2016-5131.patch"))))))
-
(define-public python-libxml2
(package (inherit libxml2)
(name "python-libxml2")
- (replacement #f)
(build-system python-build-system)
(arguments
`(;; XXX: Tests are specified in 'Makefile.am', but not in 'setup.py'.