summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:50:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:36 +0100
commit315118995a02dd96e8435907551b74fa489e05ad (patch)
treeb10134f43f96a7e7b03b29829cec02e68e93f108 /gnu/packages/xml.scm
parent6f8deed6e3b945dd2c9622a24ff3b1ee3226a920 (diff)
downloadpatches-315118995a02dd96e8435907551b74fa489e05ad.tar
patches-315118995a02dd96e8435907551b74fa489e05ad.tar.gz
gnu: Add ghc-hxt..
* gnu/packages/xml.scm (ghc-hxt.): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 480e65073b..919043afd4 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2085,3 +2085,31 @@ all Unicode character sets and blocks. It is implemented by the technique of
derivations of regular expressions.")
(license license:expat)))
+(define-public ghc-hxt
+ (package
+ (name "ghc-hxt")
+ (version "9.3.1.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/hxt/hxt-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1qq3ykgn355rx242xjcbqqksgvwr6k2fdj5phw4iv28qqxff6m8d"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-parsec" ,ghc-parsec)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-hxt-charproperties" ,ghc-hxt-charproperties)
+ ("ghc-hxt-unicode" ,ghc-hxt-unicode)
+ ("ghc-hxt-regex-xmlschema" ,ghc-hxt-regex-xmlschema)
+ ("ghc-network-uri" ,ghc-network-uri)))
+ (home-page "https://github.com/UweSchmidt/hxt")
+ (synopsis "Collection of tools for processing XML with Haskell")
+ (description
+ "The Haskell XML Toolbox bases on the ideas of HaXml and HXML, but
+introduces a more general approach for processing XML with Haskell.")
+ (license license:expat)))