summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-20 17:01:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-20 17:01:39 +0100
commit2c76e19df4b0b4aa0171f1edd9f240f7b6ba5b84 (patch)
treec2e7a7f27dd9c7e704f2e78655328c903a6934d1 /gnu/packages/xml.scm
parente6a668ec7303a71f87e4c9354b1458e555058c63 (diff)
parent78b2eb1ad3dcf05c25e0ee4980c97aa52de03a2d (diff)
downloadpatches-2c76e19df4b0b4aa0171f1edd9f240f7b6ba5b84.tar
patches-2c76e19df4b0b4aa0171f1edd9f240f7b6ba5b84.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm36
1 files changed, 2 insertions, 34 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 52f1533699..c80dfb1eac 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -404,7 +404,7 @@ combination with @code{XML::Parser}, PerlSAX, @code{XML::DOM},
(define-public perl-xml-libxml
(package
(name "perl-xml-libxml")
- (version "2.0132")
+ (version "2.0134")
(source
(origin
(method url-fetch)
@@ -412,7 +412,7 @@ combination with @code{XML::Parser}, PerlSAX, @code{XML::DOM},
"XML-LibXML-" version ".tar.gz"))
(sha256
(base32
- "0xnl281hb590i287fxpl947f1s4zl9dnvc4ajvsqi89w23im453j"))))
+ "1ks69xymv6zkj7hvaymjvb78ch81abri7kg4zrwxhdfsqb8a9g7h"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-xml-namespacesupport" ,perl-xml-namespacesupport)
@@ -1254,38 +1254,6 @@ files. It is designed to be fast and to handle large input files.")
(define-public python2-defusedxml
(package-with-python2 python-defusedxml))
-(define-public libxls
- (package
- (name "libxls")
- (version "1.4.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://sourceforge.net/projects/"
- name "/files/" name "-"
- version ".zip"))
- (sha256
- (base32
- "1g8ds7wbhsa4hdcn77xc2c0l3vvz5bx2hx9ng9c9n7aii92ymfnk"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Bootstrapping is required in order to fix the test driver script.
- (replace 'bootstrap
- (lambda _
- (invoke "bash" "bootstrap"))))))
- (native-inputs
- `(("unzip" ,unzip)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
- (home-page "http://libxls.sourceforge.net/")
- (synopsis "Read Excel files")
- (description
- "libxls is a C library which can read Excel (xls) files since Excel 97 (the BIFF8 format).
-libxls cannot write Excel files.")
- (license license:bsd-2)))
-
(define-public freexl
(package
(name "freexl")