summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-05-01 22:24:49 +0200
committerAndreas Enge <andreas@enge.fr>2013-05-01 22:26:10 +0200
commit21e9fee042e47aab42bbe785f94cac64ed6fec73 (patch)
tree96859ff3f3597312896fdee4631bed7ddf02d951 /gnu/packages/xml.scm
parentd515cb555cf88893db6622a12c7be54ef2ef178a (diff)
downloadpatches-21e9fee042e47aab42bbe785f94cac64ed6fec73.tar
patches-21e9fee042e47aab42bbe785f94cac64ed6fec73.tar.gz
gnu: Have python paths set automatically..
* gnu/packages/xorg.scm (meas): Drop special handling of python paths. * gnu/packages/xml.scm (libxslt): Drop special handling of python paths.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 524614b23f..6edff473da 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -103,17 +103,6 @@ things the parser might find in the XML document (like start tags).")
("libxml2" ,libxml2)
("python" ,python)
("zlib" ,zlib)))
- (arguments
- `(#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (let ((configure (assoc-ref %standard-phases 'configure))
- (libxml2 (assoc-ref inputs "libxml2")))
- ;; FIXME: This should be done more centrally.
- (setenv "PYTHONPATH" (string-append libxml2 "/lib/python2.7/site-packages"))
- (apply configure args)))
- %standard-phases)))
(description
"Libxslt is an XSLT C library developed for the GNOME project. It is
based on libxml for XML parsing, tree manipulation and XPath support.")