summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-14 14:35:56 -0400
committerLeo Famulari <leo@famulari.name>2017-07-14 15:19:26 -0400
commitda83f0953a040c2f58da7647dc5d773b430e7098 (patch)
treedeb0ca6c3792a82e1fa516d07a7eb5c3f974d869 /gnu/packages/xml.scm
parent51ccb1be5532c5001003644a43cfdc5596ff5f92 (diff)
downloadpatches-da83f0953a040c2f58da7647dc5d773b430e7098.tar
patches-da83f0953a040c2f58da7647dc5d773b430e7098.tar.gz
gnu: expat: Update replacement to 2.2.2 [security fixes].
See 'Changes' in the source distribution for more information about the fixed security issues. * gnu/packages/xml.scm (expat)[replacement]: Update to 2.2.2. (expat-2.2.1): Replace with ... (expat-2.2.2): ... new variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 67d6c8e8df..143b8d1f6a 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -56,7 +56,7 @@
(package
(name "expat")
(version "2.2.0")
- (replacement expat-2.2.1)
+ (replacement expat-2.2.2)
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/expat/expat/"
@@ -75,17 +75,17 @@ stream-oriented parser in which an application registers handlers for
things the parser might find in the XML document (like start tags).")
(license license:expat)))
-(define expat-2.2.1 ; Fixes CVE-2017-9233, CVE-2016-9063 and other issues.
+(define expat-2.2.2 ; Fixes CVE-2017-9233, CVE-2016-9063 and other issues.
(package
(inherit expat)
- (version "2.2.1")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/expat/expat/"
version "/expat-" version ".tar.bz2"))
(sha256
(base32
- "11c8jy1wvllvlk7xdc5cm8hdhg0hvs8j0aqy6s702an8wkdcls0q"))))))
+ "0ik0r39ala9c6hj4kxrk933klgwkzlkbrfhvhaykx8l1rwgr2xj3"))))))
(define-public libebml
(package