summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-23 08:23:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 00:04:14 +0200
commit3b6958021df2d26a56b3ae78cff9f08cd79f06fc (patch)
tree8cd23e07e5de9d6f211798510e01c29ff06789cf /gnu/packages/xml.scm
parent6768e0a7a5f7171bf21db61e02c9de4d5776c682 (diff)
downloadpatches-3b6958021df2d26a56b3ae78cff9f08cd79f06fc.tar
patches-3b6958021df2d26a56b3ae78cff9f08cd79f06fc.tar.gz
gnu: Add perl-xml-xpathengine.
* gnu/packages/xml.scm (perl-xml-xpathengine): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d889e602ed..add9311a82 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1266,3 +1267,28 @@ This framework aids the development of XML systems with minimal effort and
reduced errors. It offers full object serialization and deserialization,
maintaining each reference encountered.")
(license license:asl2.0)))
+
+(define-public perl-xml-xpathengine
+ (package
+ (name "perl-xml-xpathengine")
+ (version "0.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MI/MIROD/"
+ "XML-XPathEngine-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r72na14bmsxfd16s9nlza155amqww0k8wsa9x2a3sqbpp5ppznj"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/XML-XPathEngine/")
+ (synopsis "Re-usable XPath engine for DOM-like trees")
+ (description
+ "This module provides an XPath engine, that can be re-used by other
+modules/classes that implement trees.
+
+In order to use the XPath engine, nodes in the user module need to mimick DOM
+nodes. The degree of similitude between the user tree and a DOM dictates how
+much of the XPath features can be used. A module implementing all of the DOM
+should be able to use this module very easily (you might need to add the
+@code{cmp} method on nodes in order to get ordered result sets).")
+ (license license:perl-license)))