summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-11 14:16:56 -0800
committerLeo Famulari <leo@famulari.name>2018-01-11 14:22:58 -0800
commite6ebc7b13225f0eddc404b7d8e136120b962181e (patch)
tree8072e9dde9639e661ded6c5dead89863778e63e5 /gnu/packages/xiph.scm
parent4adb40bffc0dda8871878283887a0e0cd88d9578 (diff)
downloadpatches-e6ebc7b13225f0eddc404b7d8e136120b962181e.tar
patches-e6ebc7b13225f0eddc404b7d8e136120b962181e.tar.gz
gnu: libvorbis: Integrate grafted patches.
* gnu/packages/xiph.scm (libvorbis)[replacement]: Remove field. [source]: Add patches from libvorbis/fixed. (libvorbis/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index e9ab06de42..a0cdd0de87 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -79,12 +79,13 @@ periodic timestamps for seeking.")
(define libvorbis
(package
(name "libvorbis")
- (replacement libvorbis/fixed)
(version "1.3.5")
(source (origin
(method url-fetch)
(uri (string-append "http://downloads.xiph.org/releases/vorbis/"
"libvorbis-" version ".tar.xz"))
+ (patches (search-patches "libvorbis-CVE-2017-14633.patch"
+ "libvorbis-CVE-2017-14632.patch"))
(sha256
(base32
"1lg1n3a6r41492r7in0fpvzc7909mc5ir9z0gd3qh2pz4yalmyal"))))
@@ -103,14 +104,6 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
"See COPYING in the distribution."))
(home-page "http://xiph.org/vorbis/")))
-(define libvorbis/fixed
- (package
- (inherit libvorbis)
- (source (origin
- (inherit (package-source libvorbis))
- (patches (search-patches "libvorbis-CVE-2017-14633.patch"
- "libvorbis-CVE-2017-14632.patch"))))))
-
(define libtheora
(package
(name "libtheora")