summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-19 23:59:20 -0500
committerMark H Weaver <mhw@netris.org>2018-01-19 23:59:20 -0500
commite074a655dd6497daafbd62737e3b63f3d5aa7985 (patch)
tree2b198ba5c664cdd58e155f3c0113d1cebde0fc91 /gnu/packages/xiph.scm
parent6d7b26a39faf42c37f15dc64a30a77e5e194ea23 (diff)
parentccb5cac17be98aaa9c3225605d6170c675d8e8e6 (diff)
downloadpatches-e074a655dd6497daafbd62737e3b63f3d5aa7985.tar
patches-e074a655dd6497daafbd62737e3b63f3d5aa7985.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index a0cdd0de87..3a9b989486 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,7 +75,7 @@ multiple data streams, ogg provides packet framing, error detection, and
periodic timestamps for seeking.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
- (home-page "http://xiph.org/ogg/")))
+ (home-page "https://xiph.org/ogg/")))
(define libvorbis
(package
@@ -102,7 +103,7 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
128 kbps/channel.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
- (home-page "http://xiph.org/vorbis/")))
+ (home-page "https://xiph.org/vorbis/")))
(define libtheora
(package
@@ -126,7 +127,7 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
a fully open, non-proprietary, patent-and-royalty-free, general-purpose
compressed video format.")
(license license:bsd-3)
- (home-page "http://xiph.org/theora/")))
+ (home-page "https://xiph.org/theora/")))
(define speex
(package
@@ -230,7 +231,7 @@ It currently supports:
@end enumerate
")
(license license:gpl2+)
- (home-page "http://www.xiph.org/ao/")))
+ (home-page "https://www.xiph.org/ao/")))
(define flac
(package
@@ -254,7 +255,7 @@ It currently supports:
meaning that audio is compressed in FLAC without any loss in quality.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution.")) ; and LGPL and GPL
- (home-page "http://xiph.org/flac/")))
+ (home-page "https://xiph.org/flac/")))
(define libkate
(package
@@ -328,7 +329,7 @@ oggdec, a simple, portable command line decoder (to wav and raw);
ogginfo, to obtain information (tags, bitrate, length, etc.) about
an ogg vorbis file.")
(license license:gpl2)
- (home-page "http://xiph.org/vorbis/")))
+ (home-page "https://xiph.org/vorbis/")))
(define opus
(package
@@ -388,7 +389,7 @@ decoding .opus files.")
(define opusfile
(package
(name "opusfile")
- (version "0.8")
+ (version "0.9")
(source (origin
(method url-fetch)
(uri (string-append
@@ -396,7 +397,7 @@ decoding .opus files.")
".tar.gz"))
(sha256
(base32
- "192mp2jgn5s9815h31ybzsfipmbppmdhwx1dymrk26xarz9iw8rc"))))
+ "0yg9whb9y6ja3d5dmscg5a29hxj7qj0asw8smisjf4hbwh0bapzp"))))
(build-system gnu-build-system)
(propagated-inputs
`(("opus" ,opus)))
@@ -411,7 +412,7 @@ decoding .opus files.")
streams in the Ogg container (.opus files) including over http(s) on posix and
windows systems.")
(license license:bsd-3)
- (home-page "http://www.opus-codec.org")))
+ (home-page "https://www.opus-codec.org")))
(define-public icecast
(package
@@ -442,7 +443,7 @@ windows systems.")
Ogg (Vorbis and Theora), Opus, WebM and MP3 audio streams. It can be used to
create an Internet radio station or a privately running jukebox and many
things in between.")
- (home-page "http://icecast.org/")
+ (home-page "https://icecast.org/")
(license license:gpl2)))
(define-public libshout