summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorL p R n d n <guix@lprndn.info>2019-09-03 15:47:07 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-04 23:41:07 +0200
commitd28b6dda86c2901e6ed852b8aee785a9ca0d10ac (patch)
treeb693a629d37f88a4c07b57b4f6d5e38cb905e970 /gnu/packages/xfce.scm
parentf475c6e53e5b6912cc45663d50f1d03dadfb60b8 (diff)
downloadpatches-d28b6dda86c2901e6ed852b8aee785a9ca0d10ac.tar
patches-d28b6dda86c2901e6ed852b8aee785a9ca0d10ac.tar.gz
gnu: Add xfce4-screenshooter.
* gnu/packages/xfce.scm (xfce4-screenshooter): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 6d2155fc53..e7848bfc28 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1087,3 +1087,36 @@ of data to either CD/DVD/BD.")
(description
"Mousepad is a graphical text editor for Xfce based on Leafpad.")
(license gpl2+)))
+
+(define-public xfce4-screenshooter
+ (package
+ (name "xfce4-screenshooter")
+ (version "1.9.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/apps/"
+ "xfce4-screenshooter/"
+ (version-major+minor version)
+ "/xfce4-screenshooter-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "135kad07922jxjs05amn48sdgm2x1rh97wbzdmy9h85r5i1vaddz"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("glib:bin" ,glib "bin"))) ; glib-genmarshal
+ (inputs
+ `(("exo" ,exo)
+ ("libsoup" ,libsoup)
+ ("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page "https://goodies.xfce.org/projects/applications/xfce4-screenshooter")
+ (synopsis "Xfce's application to take screenshots")
+ (description
+ "This application allows you to capture the entire screen, the active
+window or a selected region. You can set the delay that elapses before the screenshot
+is taken and the action that will be done with the screenshot.
+A plugin for the Xfce panel is also available.")
+ (license gpl2+)))