summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:24 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:27:13 +0200
commit820a0869eaf662c60451afcee7cdc7e2574ed686 (patch)
tree8492e24b467e23772793d7bfb0ecfb27af1c284f /gnu/packages/xfce.scm
parent415e7e2046ea8eeb7fa0cf3ccb51429be2ca2627 (diff)
downloadpatches-820a0869eaf662c60451afcee7cdc7e2574ed686.tar
patches-820a0869eaf662c60451afcee7cdc7e2574ed686.tar.gz
gnu: Add xfce4-systemload-plugin.
* gnu/packages/xfce.scm (xfce4-systemload-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index e3ff59eed1..cae32aeb09 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1230,6 +1230,34 @@ A plugin for the Xfce panel is also available.")
the volume using multimedia keys. It also provides volume change notifications.")
(license gpl3+)))
+(define-public xfce4-systemload-plugin
+ (package
+ (name "xfce4-systemload-plugin")
+ (version "1.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-systemload-plugin/"
+ (version-major+minor version)
+ "/xfce4-systemload-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0x87a8h5l3ashz1ksfaxcpn9a392jzlsbx5n5pga8g90fp2hf905"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-systemload-plugin")
+ (synopsis "System load display plugin for the Xfce panel")
+ (description "A system load plugin for the Xfce4 desktop
+environment. It displays the current CPU load, the memory in use, the
+swap space and the system uptime in the Xfce4 panel.")
+ (license bsd-2)))
+
(define-public xfce4-timer-plugin
(package
(name "xfce4-timer-plugin")